Home > Cannot Load > Rails Cannot Load Zlib

Rails Cannot Load Zlib


Dowload Ruby source code and install it ( Ruby 1.9.1-p376 (md5: ebb20550a11e7f1a2fbd6fdec2a3e0a3) from http://www.ruby- lang.org/en/downloads/ $ ./configure; make; sudo make install Here is the result : Code: [email protected]:/usr/local/bin$ ruby -v ruby May 5, 2014 at 9:20 AM Benjamin Harel said... The time now is 02:32 PM. Someone peeled an American flag sticker off of my truck. http://stevemattley.com/cannot-load/rails-cannot-load-helper.html

Ruby 2.2.1 works fine but 2.2.2 causes this issue whenever I try to install a gem. Adv Reply November 9th, 2010 #7 brezenix View Profile View Forum Posts Private Message First Cup of Ubuntu Join Date Jun 2008 Location Moscow, Russia Beans 1 DistroUbuntu 10.10 Maverick Browse other questions tagged ruby gem or ask your own question. I am using Fedora, so I used yum to install rvm, but can't seem to get that working either. http://stackoverflow.com/questions/9727908/cannot-load-such-file-zlib-even-after-using-rvm-pkg-install-zlib

Ruby Gem Install Cannot Load Such File -- Zlib

But using Gentoo to install Gems is not easier either. On the top off the page is a "Quick fix" follow it's instructions, it will: fix your installation, provide you instructions what to do to install zlib from your system and On Ubuntu 10.04 I install zlib1g and zlib1g-dev. Its a little unsatisfiying through, because I'm not sure exactly what part of that tutorial fixed the gem install.

GO OUT AND VOTE US Election results 2016: What went wrong with prediction models? Yes, I have zlib and zlib-devl > installed. Join Date Oct 2004 Location USA Beans 330 DistroUbuntu 16.04 Xenial Xerus Re: Can't install Ruby on Rails Is there a specific reason you are installing ruby and rubygems from source? "cannot Load Such File -- Date" Should I report it?

History Link existing bug Create bug report Link to a FAQ Create a new FAQ To post a message you must log in. Undefined Method `invoke_with_build_args' For Nil:nilclass What is the most efficient & fastest way to speed up the installation of packages with thousands of items? Also as you can see I have zlib[devel] installed. http://stackoverflow.com/questions/30233255/error-installing-gems-cannot-load-such-file-zlib Thank you for replying.

On a RedHat derivative it would look something like this: sudo yum install zlib-devel For ubuntu: sudo apt-get install zlib1g-dev Hope this helps share|improve this answer answered Nov 15 '14 at Error: Loading Command: Install (loaderror) more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed Linked 0 Beginning Ruby on Rails in Linux Mint Related 128Ubuntu noob rails install fails on zlib385Error installing mysql2: Failed to build gem native extension99cannot load such file — zlib even http://www.lucas-nussbaum.net/blog/?p=550 brezenix has the right idea.

Undefined Method `invoke_with_build_args' For Nil:nilclass

Safety - Improve braking power in wet conditions On 1941 Dec 7, could Japan have destroyed the Panama Canal instead of Pearl Harbor in a surprise attack? How do pilots identify the taxi path to the runway? Ruby Gem Install Cannot Load Such File -- Zlib At any rate thanx so much for the link. Cannot Load Such File -- Zlib Mac Get:1 http://se.archive.ubuntu.com/ubuntu/ precise/main zlib1g-dev i386 1: [162 kB] Fetched 162 kB in 0s (729 kB/s) Selecting previously unselected package zlib1g-dev. (Reading database ... 181624 files and directories currently installed.) Unpacking zlib1g-dev

Mimsy were the Borogoves - why is "mimsy" an adjective? http://stevemattley.com/cannot-load/ruby-cannot-load-such-file.html That probably means you don't have the zlib package installed. Do you want to help us debug the posting issues ? < is the place to report it, thanks ! They even have a section that addresses the zlib problem. Gem Cannot Load Such File -- Zlib Centos

I'm not using RVM with the current installation. Report post Edit Delete Reply with quote Re: Re: can't install rails - gem is asking for a zlib Zoltan Gero (gezope) on 2010-09-01 23:53 Ah, Ubuntu, cool ;) than try: See my output below > for what I have installed, and the error I get when I try and run any > gem commands. http://stevemattley.com/cannot-load/rails-cannot-load-such-file-helper.html Yes, I knew that.

more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed Gem Install Bundler Error Loading Command Install (loaderror) I can't seem to install > any gems due to the zlib problem. Join them; it only takes a minute: Sign up cannot load such file --zlib up vote 1 down vote favorite Ruby & Rails beginner here!

Report post Edit Delete Reply with quote Re: Re: can't install rails - gem is asking for a zlib Colin Law (Guest) on 2010-12-29 15:07 On 29 December 2010 14:00, Mark

more hot questions question feed lang-rb about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation Colin Report post Edit Delete Reply with quote Re: can't install rails - gem is asking for a zlib Mark Locklear (mark_l) on 2010-12-29 15:00 I did make the changes in but I couldn't find a good answer for my problem, so I'm here. Recompile Ruby when run this command gem install rails I gave this error: ERROR: Loading command: install (LoadError) cannot load such file -- zlib ERROR: While executing gem ... (NoMethodError) undefined method ``invoke_with_build_args'

Or can I just install RVM at this time? –ltrainpr May 30 '13 at 13:11 Installed RVM and everything is working. Lab colleague uses cracked software. rvm doesn't seem to be in my > path, and I can find an executable for it in the .rvm folder. have a peek here Lab colleague uses cracked software.

Registration is free and takes only a minute. How much time would it take for a planet scale Miller-Urey experiment to generate intelligent life Bhagavad Geeta 4.14 Will I get the same result if I use 18-55mm lens at What is a satisfactory result of penetration testing assessment? Not the answer you're looking for?

My cat sat on my laptop, now the right side of my keyboard types the wrong characters Would we find alien music meaningful? Possible repercussions from assault between coworkers outside the office C++ calculator using classes What does "there lived here then" mean? Double quote value assignments stored in a CSV? Although I had to recompile once more since I was missing libssl-dev too (I needed it because rvm wanted to fetch the ruby sources via HTTPS) :-) –tr9sh Feb 13 '14

Gentoo handle Ruby installation slightly better without need rvm to manage Ruby and then Gems manage gems. Polyglot Anagrams Cops' Thread C++ calculator using classes Do the Leaves of Lórien brooches have any special significance or attributes? Join Date Oct 2007 Beans 74 Re: Can't install Ruby on Rails To the original poster: Rails is not compatible with ruby 1.9.1, you have to use 1.9.2 or 1.8.7. Any help appreciated...thanx! [[email protected] ruby-1.9.2-p136]# ruby -v ruby 1.9.2p136 (2010-12-25 revision 30365) [i686-linux] [[email protected] ruby-1.9.2-p136]# gem -v 1.3.7 [[email protected] ruby-1.9.2-p136]# rails -v Rails 2.3.5 [[email protected] ruby-1.9.2-p136]# gem install rails ERROR: Loading

Some one > mentioned something about the headers being installed with zlib??? Dowload Ruby gem and install it (rubygems-1.3.7.tgz from http://rubyforge.org /frs/?group_id=126) [email protected]:~/Downloads/rubygems-1.3.7$ ruby setup.rb .............. Because then you can do rvm requirements This will probe your particular OS and produce a set of commands you can copy back to the command line to install those missing tAp's blog Friday, October 4, 2013 Installing Ruby: cannot load such file -- [ openssl | zlib ] If you like me, installed Ruby by compiling from source code manually, and

Done Building dependency tree Reading state information... Ballpark salary equivalent today of "healthcare benefits" in the US? Possible repercussions from assault between coworkers outside the office Can Trump undo the UN climate change agreement? Not sure why ruby isn't finding the headers. –ptierno Nov 15 '14 at 17:27 here is the output : ii zlib1g:amd64 1:1.2.7.dfsg-13 amd64 compression library - runtime ii zlib1g-dev:amd64